How to connect my Lumo Lift (iOS)?

Follow

 

 Please Note: This video is relevant only for iOS users who are using the Lift App Versions 3.19.3 or earlier.

 

 

Was this article helpful?
0 out of 0 found this helpful

Comments